1993 Mazda RX-7 Montego Blue FD Twin Turbo

Price: US $10,500.00 Item location: Yorkville, Illinois, United States
  • Condition: Used
  • Make: Mazda
  • Model: RX-7
  • Year: 1993
  • Mileage: 98,800
  • VIN: JM1FD3319P0207534
  • Color: Blue
  • Engine size: 1.3 L Rotary
  • Power options: Air Conditioning, Cruise Control, Power Locks, Power Windows, Power Seats
  • Fuel: Gasoline
  • Transmission: Automatic
  • Drive type: RWD
  • Interior color: Tan
  • Drive side: Left-hand drive
  • Options: Leather Seats, Sunroof
  • Vehicle Title: Clear
  • Want to buy? Contact seller!
Description:

1993 Mazda RX-7

I am posting my beloved project - 1993 Mazda Rx-7 Twin Turbo; Montego Blue. 98,800 miles.
The car was born in Tampa, Florida. Came to Illinois in 2005. No Rust. No accidents. Clean title. Autocheck available. Score of 49/53.
The car has no visible rust at all - the undercarriage looks amazingly well taken care of.
The car starts and idles, however does not run past 5MPH it's like in LIMP mode and not sure exactly what the issue is. I suspect it's a grounding issue. Again, I have no clue - not a mechanic.
Here is the story behind this car - I purchased it last year (clean title) and planned to build the car.
According to the last owner the car had an engine replacement (13B) at 74,000 miles. Therefore, engine has approximately 25K miles.
When I purchased the car, the seller failed to point out that the car had a major fuel leak from the FPD (Fuel Pulsation Damper) as well as other components. When I purchased the car and filled it up with gas, I could smell the gas from within the car, parked it as soon as I could and began the diagnostic as it became a hazard.
Anyhow - ended up replacing a whole bunch of parts with new OEM. Below is the list.
MOD's from prior owners (with receipt):
ASPEC racing Down Pipe
-KOYO Radiator
-Greddy Gauges and Pillar Pods:
- Boost
- Water Temp
- Oil Pressure
- Tein Street Racing Coilovers
- Racing Motor Mounts
What I replaced:
- Fuel Pulsation Damper
- Fuel Pressure Regulator
- Sent the Injectors to Injector Rehab to have them cleaned, flow tested, and replaced the below (injectors running perfect, have receipt and test results). Both Primary and Secondary injectors.
Upper O-Ring's
Lower O-Ring's
Pintle Cap's
Injector Filter's
Replaced all three fuel hoses for fuel rail (1. Fuel Pressure Regulator, Fuel Pulsation Damper, Primary to Secondary Rail) - From Dealer
Upper Intake Manifold Gasket - From Dealer
MISC. Vaccum Hoses
Coolant Temp Sensor
Fuel Temp Sensor - From Dealer
Auto Trans Coolant sensor
OMP Oil Line #1- From Dealer
OMP Oil Line #2 - From Dealer
Mobil 1 Oil + Mobil 1 Filter
Pre Control Solonoid
Turbo/Wastegate Control Solonoids
Ignition/Spark Plug Wires
Tires look good.Brakes are fair.
The car was running perfectly fine after replacing all the above mentioned components and then all of the sudden it started running bad.
To the best of my knowledge (I am not 100% familiar with rotary engines) here is what I see that needs attention:
1. The car starts right up and runs, just can't drive it past 5mph. Cannot drive it (need to tow it). Unless you like driving the car at 5 MPH.
2. Tachometer works intermittently.
3. I believe there is a small leak from the transmission. I'll have to confirm.Might also leak a bit of oil or something from engine.
4. Front bumper has a few peeled spots. Some smaller door dings on both doors. Minor scratch on hood.
The car is sold as is - you are responsible for inspecting the vehicle and ensuring it is what you want. No returns whatsoever and no warranty or guarantee whatsoever. Private seller - not a dealer.
Have spent a substantial amount of money in getting the car running right. Most parts purchased from the dealer or a respectable and well known source. I have receipts for it all, except for the engine replacement. About $1,000 in maintenance parts in the last couple months alone.
The best part is that you are purchasing an extremely rare FD, Montego blue, Sun Roof, no rust at all, paint is very nice, tan leather interior, with name brand aftermarket parts, also the car has been maintained well. A/C and heater both work.
The car has no check engine lights on - it HAD one for the pre-control solenoid (circuit malfunction). Fixed it.
Let me know if you have any further questions.