1966 Chrysler, New Yorker, Town & Country

Price: US $15,000.00 Item location: Hopkinton, Massachusetts, United States
  • Condition: Used
  • Make: Chrysler
  • Model: Town & Country
  • Type: Wagon
  • Year: 1966
  • Color: Maroon
  • Engine size: 383
  • Number of cylinders: 8
  • Power options: Cruise Control, Power Seats
  • Fuel: Gasoline
  • Transmission: Automatic
  • Drive type: RWD
  • Interior color: Pewter
  • Vehicle Title: Clear
  • Want to buy? Contact seller!

1966 Chrysler Town & Country

Up for auction 1966 Chrysler car is virtually survivor, 85% original paint, interior all original, trim excellent,chrome very nice front bumper a little dry car is very straight has a few minor blemishes, over the rear wheel opening there are a few small bubbles, this is the 15% paint work that must have been done years ago, it is not severe, overall condition is excellent car was sold new in Vermont so the fact it's in such good shape shows how well it was cared for, underneath is spotless no rust ever, it wouldn't take much to make the car show worthy. The driver seat on the upper bolster is showing some wear as is the windlace around the door opening only at the back of the jamb. Carpet dash steering wheel headliner all near perfect. Dash pad is mint, looking under the hood the engine appears to have had a valve job at some point, and basic maintenance as needed. The car rides on a new set of 15" magnum wheels with new tires and complete new dual exhaust. Car runs and drives great. Has all the original glass and is near perfect, car gets tons of attention, drive as is and enjoy or fix some of the few items and detail the engine and go to the car shows it will be a hit. Feel free to ask questions and come inspect, please do not bid unless you are planning to purchase, you are entering a binding contract. I reserve the right to end auction as the car is for sale locally. I can help arrange transportation at the buyers expense. Check feedback thank you and good luck. 508-989-6519 car has 100,000 miles on it I couldn't get it to state in the mileage icon.